1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. Greetings Guest, Having Login Issues? Check this thread!
    Dismiss Notice
  4. Hail Guest!,
    Please take a moment to read this post reminding you all of the importance of Account Security.
    Dismiss Notice
  5. Author Wes Locher has teamed up with Stratics for a giveaway of his new book Braving Britannia. This book explores the history and impact of Ultima Online and includes interviews from current and past dev team members as well as many UO and Stratics community members. Click here for more details!
    Dismiss Notice

Question about Free Play accounts

Discussion in 'EA Land/The Sims Online Stratics Forums' started by jafo1972, Feb 25, 2008.

  1. jafo1972

    jafo1972 Guest

    I reactivated an old account after I got the e-mail. This morning I log in to play and get a message saying that account has expired. I went to update my info and only got an option to subscribe for $9.99 a month.

    How do I make this a free account? I'm still not convinced I want to come back to a paying account and having this happen is not very encouraging.

    Just tried again after reading the reply I got and got the following error message:
    Unknown login error has occured. The following problem has been reported: We're sorry, but your game registration has expired. The public test period for this game may have ended. Please purchase and install the retail version. (INV-223)
     
  2. Paula777

    Paula777 Guest

    I could just log in with my expired accounts, didn't have to reactivate anything.
    Sry dunno, just thought i'd add my expirience. Good Luck!
     
  3. jafo1972

    jafo1972 Guest

    Finally got it. All the ealand sites were not working when I tried earlier. They finally came back up and I found the info I needed. I thought I had logged in using the tsopatch.exe but I might not have.

    At any rate I am back in the game.