1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. Greetings Guest, Having Login Issues? Check this thread!
    Dismiss Notice
  4. Hail Guest!,
    Please take a moment to read this post reminding you all of the importance of Account Security.
    Dismiss Notice
  5. Author Wes Locher has teamed up with Stratics for a giveaway of his new book Braving Britannia. This book explores the history and impact of Ultima Online and includes interviews from current and past dev team members as well as many UO and Stratics community members. Click here for more details!
    Dismiss Notice

UOAssist Problems

Discussion in 'UO Resources' started by Silk7, Feb 8, 2010.

  1. Silk7

    Silk7 Guest

    Greetings, I am having trouble running UOAssist, resulting in error messages. Example: Data stream has changed and UO MAY not function correctly. An update or UOAssist DLL may be needed for UOAssist to load correctly. If I do get it to work, it is only for aprroximately 3-4 minutes. If I log-on and after I get a crash error message, it will not load at all for the following 6-7 hours. This problems occurs right after I put in my password. I have tried doing the updates, I uninstalled UOAssist completely and re-installed it and nothing has helped. I have emailed tugsoft repeatedly with no response, in the last week! I have a Windows 7 OS on my laptop and it is the one giving me trouble. My desktop is running smooth with, no problems loading UOAssist. Does anyone have any ideas on what I need to do? I can not evcen load UO by itself, without UOAssist! Could this be a bug affecting only the Windows 7 OS or a combination of Windows 7 and SA?
    Help!!!! :rant2:
  2. ElvishArcher

    ElvishArcher Journeyman
    Stratics Veteran

    Jan 15, 2009
    Likes Received:
    I have had no problems resembling yours and use Win7 as well. I do have questions as to proper install of UOAssist (thats in another thread I created here) but the prob you are having... nothing like that on my end. Win7 actually runs UO smoother than I have seen in years. I'm thinking its UOAssist related somehow. Would be interested in hearing how you fix this (if you fix it) and wish you the best of luck.
  3. jfkeach

    jfkeach Guest

    RIGHT click on UOAssist installer when you go to install, and select from the menu, RUN AS ADMINISTRATOR.

    Once UOAssist is installed, right click on the ICON for it, and select properties, then on the Compatibility TAB select Run as Administrator then apply.

    WIN 7 has different security model than UO or UOAssist is designed for. These programs are trying to make calls to DLL's on your computer and unless you give it the ACCESS to do so by running as administrator, they will fail.
  4. Silk7

    Silk7 Guest

    :thumbup: Thanks, for your reply. I did select to run UOAssist as Administrator, but it still didn't work. I am going to un-install UOAssist and re-install it again and follow your instructions. I will let you know if it worked. Thanks so much for your help. :thumbup:
  5. Calla Lily

    Calla Lily Guest

    I can't get into UO either using UOA and am getting the same message as the OP. When I try to run it as administrator, it asks for a password. What password?

    Why is this happening, and is it going to be fixed?
  6. Schuyler Bain

    Schuyler Bain Lore Master
    Stratics Veteran Stratics Legend

    May 19, 2008
    Likes Received:
    The Password is your windows password and since it is asking it means your account is most likely not set as an admin on for the PC you are using. Perhaps someone else setup your PC and they are the admin? If so you need their password.

    It is not something that needs "fixed" it is a Win 7 thing that you need to work with.

    I have been using UOA, the classic client and the enhanced client all with Win 7 pro and they all run just fine. Of course I am full admin for my PC so that may be the difference.

    Good luck.