1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. Greetings Guest, Having Login Issues? Check this thread!
    Dismiss Notice
  4. Hail Guest!,
    Please take a moment to read this post reminding you all of the importance of Account Security.
    Dismiss Notice
  5. Author Wes Locher has teamed up with Stratics for a giveaway of his new book Braving Britannia. This book explores the history and impact of Ultima Online and includes interviews from current and past dev team members as well as many UO and Stratics community members. Click here for more details!
    Dismiss Notice

using proxy/socks/http tunnel

Discussion in 'UO Resources' started by dupadupa, Feb 8, 2010.

  1. dupadupa

    dupadupa Guest

    let me explain...

    i was using "pingfu iris" to tunnel UOSA through my work firewall - which worked lovely.... problem is that they have vanished over the last ten days, my paid suscription will not log in - 90% of the time there website is totally off - and 98% even if the website has been back up the support forums are not, not sure what going on but ive been looking at alternatives to play uo,

    this is where i need HELP

    been trying to use "HTTP-tunnel client" with "proxifier" and/or "sockscap V2", without success - the patch part of the client pops up fine in "proxifier" and i can see the out going/incoming connections through "http-tunnel" so thats all good, but the issue i have is once im onto the main login screen no new connections are made against UOSA.exe. as you can imagine it just times out,

    question is... has anyone got these combo's or any other combo's of programs working for Enhanced client (2d will play but im a total non 2d player)

    oh and adding the uosa.exe into "sockscap" loads the client but again fails to take any connections from the uosa.exe

    btw before someone says that i should not negate the security put in place or speak to admins at my work, please read that i am the IT administrator, and i put the security in-place myself, but im sure you can understand its something that i dont want to open to the outside world in terms of open ports to certain ip's but rather would tunnel through 80 or 443 which are already open, afterall its a corporate enviroment, just want some uo as safe as poss whilst on lunch

    many thanks in advance

  2. Basara

    Basara UO Forum Moderator
    Moderator Professional Governor Stratics Veteran Wiki Moderator Stratics Legend Campaign Supporter

    Jul 16, 2003
    Likes Received:
    Remember that the client patchers and the actual clients are different programs from each other, and that they use different ports as well, IIRC.

    I'm sure that was already part of your equation, but it never hurts to remind someone if they are having to redo something from scratch that they did months or years previous, with different port-affecting software than what they originally used.
  3. Monkey

    Monkey Guest

    I'm pretty much wondering the same thing. Stuck behind a proxy here, NOT at work but at a university dorm basically, and I've been trying various stuff without luck. The administrator told me he's pretty much opened up every port, but I still couldn't log on. I've tried sockscaps and some sort of ''Freedom'' program, all without luck.
  4. Monkey

    Monkey Guest

    I succesfully logged onto Testcenter a few minutes ago, followed this tutorial to get it working. I'm pretty ecstatic, eventhough it was REALLY slow, but I'm confident my real server'll be somewhat faster at least.

  5. dupadupa

    dupadupa Guest

    Question monkey: are you useing 2d? or EC? im trying to get EC running

    basara, thanks for the reminder, i have been treating them as seperate and have been trying to forwarded UOSA.exe and not the patcher as the pather will work regadless of the CORP firewall
  6. jimmypee

    jimmypee Guest

    This is something I've been investigating too.

    I can get the classic client working through https proxy using Proxifier. It's nice and smooth but I can't get the EC working. It doesn't work even if I tunnel all traffic through Proxifier.

    UOSA.exe tries to connect to but gets stuck in SYN_SENT state which means the TCP handshake never gets completed. I'm quite baffled with this problem.