1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. Greetings Guest, Having Login Issues? Check this thread!
    Dismiss Notice
  4. Hail Guest!,
    Please take a moment to read this post reminding you all of the importance of Account Security.
    Dismiss Notice
  5. Author Wes Locher has teamed up with Stratics for a giveaway of his new book Braving Britannia. This book explores the history and impact of Ultima Online and includes interviews from current and past dev team members as well as many UO and Stratics community members. Click here for more details!
    Dismiss Notice

When did my Dexxer turn into a pacifist (Losing target / attack stance)

Discussion in 'UHall' started by Ozzmandias, Feb 22, 2010.

  1. Ozzmandias

    Ozzmandias Guest

    Hi All

    I've done some searching, and not found much so thought I'd ask here. I've been heading off to Medusa quite a bit, and once in a while (Not all the time) My dexxer refuses to fight back.

    In war mode, double click to attack, he starts swinging, all good so far.

    Then after a swing or two, he stops fighting, and just sits there getting beaten up.

    So I double click again, and he takes a swing or two then stops again.

    Long story short, I spent 15 mins constantly double clicking her bar, my hand hurt, I couldn't cast any spells like corpse skin or even check my gorgon lens charges for fear of stopping swinging.

    Does this ring a bell with anyone? When it happened, it would happen with every monster in Medusa's lair not just her.

    It has happened more than once.

    It has happened solo and with a group.

    A few thoughts:

    While it was happening I dragged her bar and it turned grey like she had invised. I grabbed her bar again, then had two bars. One stayed solid, one turned grey every 2-3 seconds then re-appeared.

    I had the newer target system enabled, but I thought this might be to blame, so disabled it while it was happening. Still had the issue.

    I deliberately allowed myself to die to 'reset' it, I also closed uo and re-opened to check, still had the issue.

    Could this be instance related... And only when I go into that particular Instance of Medusa does is happen?

    Lastly, since I know you'll ask, I'm using 2d (legacy makes me sound old).

    Hopefully someone out there has noticed something odd going on, If you have noticed this happening elsewhere then please shout, it's driving me nuts!


  2. Sonoma

    Sonoma Guest

    May be a silly question but are you using Gorgon Lenses? If not one of her special moves is that she turns you to stone during which time you just stand there and take punishment.
  3. BeefSupreme

    BeefSupreme Guest

    I thought I read something about this happening to people in the Abyss...
  4. LordDrago

    LordDrago Certifiable
    Stratics Veteran Stratics Legend

    Jun 26, 2004
    Likes Received:
    Is he a Liberal? :) Sorry, couldn't resist.

    Is it possible that Medusa and some other creatures have some sort of peaceing ability?
    Also, does he auto defend when that happens? Was wondering if this might be something put in but not published to mess with scriptors farming. If their characters drop out of war mode and die, the scriptor might come back after a couple of hours, and find themselves dead, but not know why. which, if this were to be the case, way to go Ozzmandias, you let the cat out of the bag :)
  5. Ozzmandias

    Ozzmandias Guest

    Hehe, yes I'm using lenses, and the hundred percent blue ones at that.

    Nono this is different, this is just not swinging.

    Re. the anti scripter comment... I know The Devs like giving us carpal tunnel syndrome, but double clicking every 1.25 seconds just to fight something is a little rough even for that kind of anti script code.
  6. Sonoma

    Sonoma Guest

    Ugh, that would be the worst possible anti-scripting idea ever. It would do nothing to stop scriptors as they could easly add in a macro to simple attack last over and over, while the real players would have to double click repeatedly... I highly doubt that this is an anti-script thing. And since he is using the lenses this must be some kind of new bug.
  7. Cear Dallben Dragon

    Cear Dallben Dragon Babbling Loonie
    Stratics Veteran Stratics Legend

    Feb 17, 2005
    Likes Received:
    I know exactly what you mean. this happens to me randomly when fighting medusa. I have to double click EVER time i want to hit here. I have yet to figure out what causes it. a definite bugger.
    edit, i see your using 2d. Im using the EC. hope it gets fixed.
  8. Ozzmandias

    Ozzmandias Guest

    Hmm, well the client difference is ruled out then, as is the diff target.

    Next is this appearing disappearing bar thing... I wonder if this is somehow related to the instance that I happen to be in.

    Y'know, on the little egg sacrifice alter thing to get in, there are three crystals... When they are green, that instance is empty, when they are red, someone is in there doing Medusa.

    I'm gonna look next time it happens, when I leave the crystal is red just for a second, then goes green again. Should be able to see which instance I was in.
  9. kinney42

    kinney42 Seasoned Veteran
    Stratics Veteran

    May 13, 2008
    Likes Received:
    This happens to my archer all the time in navery.
  10. Coragin

    Coragin Guest

    It has to do with snake charming and getting bugged because of either not killing the snake you charmed to get the eggs or charming too many at once or killing the one you charmed before it makes it to its destination.

    idk why, but after I made a stealth charmer, it dont happen.
  11. Lyconis

    Lyconis Sage
    Stratics Veteran

    May 20, 2008
    Likes Received:
    I don't know much about the new stuff but here's my two cents.
    Perhaps a bug with the targeting system. I know with poison fields you'll switch targets like crazy hitting the last target poisoned. Perhaps you are having a similar effect with a weapon that has hit area affect, whirlwind, holy light or something similar.

    A solution so you don't break your mouse.
    Use the attack last macro, use something like a bandage and heal the desired target then hold down your attack last macro key. This can also be useful for the lazy when a mob is running away it will lure them back to you (well for most mobs).

    Also be sure you aren't using any third party applications/scripts to heal, chug, fight for you.
  12. Ozzmandias

    Ozzmandias Guest

    Hmm, now this is getting somewhere, I did go straight into Medusa having harvested the eggs with my Dexxer, and y'know, once in a while I kill the one I charmed.

    Odd that this seemed to continue through death, and also a client restart, and If I was correct, actually through server up as well. I wish I had paid a little more attention at the time.

    This is, however, the best suggestion yet, thankyou!
  13. Ozzmandias

    Ozzmandias Guest

    No third party except UOassist here, and that's just for arm/disarm and dress mainly.

    The attack last target macro I did try to create on the fly, I'm not sure but it seemed to confuse the other key presses for my essential pally/bushy spells. In the end I had to go back to using the mouse so I didn't stop the other spells working.

    Will try it again, perhaps I just chose a bad key combination.

  14. Coragin

    Coragin Guest

    Your very welcome. Now some things I can tell you about this bug.

    1. It will only effect you in SA, I was able to goto ilsh and do a champ spawn just fine. Back to SA same thing had to continously click to keep attacking.

    2. Its nice for honoring as you wont instaly hit a creature that flags you, although this is the only good thing, unless you count Blood Oath, you just stop attacking lol.

    3. Client restarts/death wont fix it.

    4. I was able to fix it, but I had to go back to where I was getting the eggs and kill all the snakes in the area, eventually I found the one that bugged me, once it was dead, I was no longer bugged. So, make sure if you have this happening to kill all the snakes in the area, should fix it.

    My guess is it has something to do with snakes un-flagging on you when you charm them somehow. Notice if you charm one that is already flagged on you, it stops being flagged and your lose the grey hue. It is turning off your auto defend as well. So, the for sure way is to go back and kill all the snakes in the area you were fighting in and it should fix it.

    Hope this info helps, sorry I didnt post it with the other post, I gave it more thought after reading the replies here.
  15. Stupid Miner

    Stupid Miner Guest

    Classic Client Macro:

    SelectNearest - Hostile

    Put the macro in a quickly accessible location, I use it a lot.
  16. Ozzmandias

    Ozzmandias Guest

    That's exactly what I use with honor target in between, used with whirlwind on a vamp it destroys champ spawns. I even clear out the Citadel rooms once in a while just to appreciate the massacre it can cause.
  17. Ozzmandias

    Ozzmandias Guest

    Excellent info mate very much appreciated, ticks all the boxes I had questions and theories on. I think you might have it bang on there!
  18. BeefSupreme

    BeefSupreme Guest

    Speaking of medusa, is there something I'm
    missing about the eggs? tried charming snakes,
    and reaching in with my hand no dice either way.
    Do I have to be out of war mode or something silly
    like that? Certain 'section' of the medusa area?
    Spent an hour using the flute and an hour trying
    my hand and not a single egg. Or is this the way it's
    supposed to be?
  19. Coragin

    Coragin Guest

    You were clicking the flute then snake then on a snake hole right?
  20. BeefSupreme

    BeefSupreme Guest

    Exactly. It works, the snake goes over there and searches, and either finds nothing or releases a horde of new snakes out of the hole... I'm on a sampire, so I can hang around with the spawn there forever.

    I did that for about an hour yesterday, then tried today with just my hand for an hour.
    Didn't get anything. Thought either it just takes a lot longer than I had time to play, or I'm doing something wrong...
  21. BeefSupreme

    BeefSupreme Guest

    How is it you put the honor target in between?
    I tried setting up the line 'invoke virtue - Honor' then a 'target last'
    in between those lines but it wasn't working all so well. I guess I'm missing something.
    I'm still so used to the built in '99 or so macros...
  22. Ozzmandias

    Ozzmandias Guest

    Just checked that Macro:

    Invoke Virtue : Honor
    Select Nearest : Hostile
    Current target (so it now honours that nearest hostile)
    Attack Selected target

    You also need to make sure that 'Disable new targetting system' is not ticked for this to work.

    It works very quickly, and if a big mob is running at you it almost always get's the honour in when I wouldn't have time to otherwise.

    Of course, once in a while it ignores Irk and honours a Dire wolf or something, but hey, it's a good start. I always found that when surrounded by a group of mobs it was impossible to keep hitting something, I'd always be trying to hit one that had wandered off.

    This way I hit Whirlwind, then hit that macro, it almost never fails.

    Of course, it does fail once in a while, and then I die. rolleyes:
  23. GalenKnighthawke

    GalenKnighthawke Grand Poobah
    Stratics Veteran

    May 12, 2008
    Likes Received:
    This has happened to me for years, usually in PvP.

    Frankly I didn't give it a second thought, just assumed it was an unwritten advantage of playing a mage (as opposed to a dexer) in UO, that as a mage you didn't have to actively maintain a target, just drop spells as appropriate and possible.

    -Galen's player
  24. Stupid Miner

    Stupid Miner Guest

    Yea, I leave out the Honor so I don't accidentally lose the Honor on something more important.
  25. Konge

    Konge Lore Master
    Stratics Veteran

    Apr 16, 2006
    Likes Received:
    Did you put in "Wait for cursor" inbetween? Yes, that option is in the classic client, not sure if it's called the same, but if you put it in your macro should work.
  26. BeefSupreme

    BeefSupreme Guest

    Great thanks! I'll give this a shot tonite. Sounds much better than trying to drag bars half the time!